Why doesn't my email link work?

The email link in a TeacherWeb site will lead users to a form that can be filled out to send a message to your site's registered email address.

If you have trouble receiving messages, this would usually indicate one of the following problems:

  1. A typing error in the text of the e-mail address.
  2. The sender has not filled out all required fields in the form, or has not entered a valid email address. (When a form is completed incorrectly, the user will see an error message indicating that the message has not yet been sent.)
  3. A problem with the ability to receive mail at your address (the most common example would be a spam filter blocking the message).

The following steps should help to address the issue:

  • Go to your Update Index, then click the My Account tab.  Check to confirm that your registered email address has been entered correctly.  If not, you can edit the address here.

  • Try sending yourself a test message using the email form.  If you receive the message successfully, this suggests that the form is working correctly.
  • If the email address is entered correctly, but you still do not receive the messages, it is possible that a spam filter on your mail system has blocked the message.  In this case, you should check your spam filter settings.  You may need to contact the administrator of your email system to inquire further.

If you need more assistance after following the above steps, please open a support ticket and provide details on the problem.

Meanwhile, please note that whenever an email is submitted to you by our system, a copy of the message is saved in the Messages section of your Update Index.  To access this section, go to your Update Index and click the Messages tab.  You can view emails here even if you have not received them at your email address.

If you do not see an email listed here, the email has not yet been successfully submitted to our system.  If an email is viewable here but has not yet been received at your email address, this means that the email was successfully submitted but a local issue has prevented it from being received (such as a spam filter, incorrect address, full mailbox, etc.).


Link:
support.teacherweb.com/index.php?action=kb&print=14