Frequently Asked Questions

Main > Grades
 

How do I import grades from Making the Grade into my Grades page?


Print
Save to list
E-mail
Subscribe
Created 2007-12-11
Modified 2009-08-26
Views 12186

Importing Grades from Making the Grade

Select Exporting/Importing either Grades Web Pages (preferred option) or Grade Records.


  • Exporting/Importing Making the Grade Web Pages
    • Before exporting grades as web pages, you need to decide whether or not to use Personal Identification Numbers (PINs) in addition to ID numbers for each student. PINs provide an additional layer of security - if used, your students will need to enter both their private ID number and PIN to access their grades. If you choose not to use PINs, students will only need to enter their ID numbers - as long as each student's ID remains private, only he/she will be able to see his/her grades.

    • To add PINs for your students if desired, open your grades file, go to the Edit menu and select "Setup Info" > "STUDENT information". In the screen that appears, scroll to the right until you find the PIN column and enter in a number for each student.

    • Open your grades file and select "EXPORT Student Data" > "The WEB ePUBLISHER: GROUPED home page documents" from the File menu.

    • If you have chosen to use PINs in addition to ID numbers, select "DO use PINs" on the screen that appears. Otherwise, choose "DO NOT use PINs". Click on "Next". Select one or more options for "Student Progress Report" type and press "Next". Choose the desired "STUDENT GROUP" ("EVERY student in this class" is usually the best option) and click "Next". Four more options pages are provided - make any desired changes and press "Next" after finishing each page. You will then be asked if you want to save changes to your class file - it is usually best to click "Yes".

    • At this point, you will reach the Save window - create a new directory/folder to store your exported files, make sure not to change the "Class list file" name which is entered as "classes.htm" by default, and press "Save". You will receive a warning message - since you have just created a new, empty directory/folder to store your files, click on "Yes".

    • To import your grades, go to your Update Grades Page and first click "Reset Gradebook to Default (if that option is visible on the page).  Then, select "I want to upload the web files my gradebook creates for me", wait for the folder upload window to load and select Making the Grade from the "How would you like to load your Grades information" drop-down box.

    • Click the "Add" button, use the mouse to select the folder on your computer that contains all of the exported files from Making the Grade and click "OK" (do not press "Open").  Click "Upload" and wait until a "Your grades have been saved" message appears at the bottom of the page.

    • When you return to your Grades Page, the original page will be replaced with your imported Making the Grade web pages.  To import a new set of grades, go to your Update Grades page by clicking the "Update" link for your Grades page on your Update Index.

    • If you are using Mac OS X, it is currently necessary to use Safari 4 (or higher) or Firefox 3 (or higher) to import your grades.

  • Exporting/Importing Making the Grade Records

    • Open your grades file and select "EXPORT Student Data..." > "Custom Export..." from the File menu. 

    • Since the TeacherWeb® Grades pages require grade data to be TAB delimited, make sure that the "use TABS as field separators" option is selected. Also, verify that "Include HEADER information" is NOT selected. 

    • Select the desired fields in the order you want them displayed. The first field must be Student Name (e.g. "Student Name: Last, First"), and the second field must be Student Number. Next, choose the other fields that contain student information. This is done by clicking on the box next to each field name to put the fields in the correct order. You will see that a number is placed in each box when you click on it. 

    • When you are done selecting the fields, either click on "Next", or if you would like to save your settings for future use, click on "SAVE This Setup", type in a title (such as "TeacherWeb"), and click on "Done". The next time you export grades, just click on "SELECT A Setup" to choose your saved settings. 

    • You will be given 2 more option screens. Generally, it is best to choose "EVERY student in this class" for "STUDENT GROUP", and on the next screen, to just use one class for each export. However, if you add multiple classes or select "Add All Classes In Folder", then check the "Export As ONE Merged File" box.  Making the Grade will produce a text file (e.g. Sample.txt).

    • To import your grades, go to your Update Grades page, select "I want to import a file I have created, or a file that my gradebook exported", and then select "Import from File" from the "How would you like to load your Grades information" drop-down box.

    • Make sure "First Row in File contains important header information" is NOT checked, select the exported text file from Making the Grade and click "Upload File".  Your grades will be imported and an "Import Succeeded" message will be displayed at the bottom of the page. 




Related Articles
How do I import grades from GradekeeperĀ® into my Grades page?
Importing Grades from Gradekeeper® Select your Exporting/Importing procedure: Grade Records - Single Class (Export to TeacherWeb® option in...
How do I import grades from Easy Grade Pro into my Grades page?
Importing Grades from Easy Grade Pro See the 1st set of instructions i f you are using Easy Grade Pro 3.6. See the 2nd set of instructions if you are...
How do I import grades from Grade MachineĀ® into my Grades page?
Importing Grades from Grade Machine® Select Exporting either Grades Records or Single Grades Web Page . Exporting/Importing Grade...